Can AppFuse 3.5 project deployed on jdk 1.6?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can AppFuse 3.5 project deployed on jdk 1.6?

firepotato
I want to use AppFuse 3.5, but want to deploy the project on WAS 7(JDK 1.6).
I also want to know which components in AppFuse 3.5 depend on JDK 7.

Thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can AppFuse 3.5 project deployed on jdk 1.6?

mraible
Administrator
There are some diamond operators used with generics. I would try generating a project with 3.5 and compiling it with Java 6. You should be able to fix the errors.

See the following two issues for Java 7-related commits:

http://issues.appfuse.org/browse/APF-1332
http://issues.appfuse.org/browse/APF-1394
 
Hope this helps,

Matt

> On Dec 29, 2015, at 10:41 PM, firepotato <[hidden email]> wrote:
>
> I want to use AppFuse 3.5, but want to deploy the project on WAS 7(JDK 1.6).
> I also want to know which components in AppFuse 3.5 depend on JDK 7.
>
> Thanks!
>
>
>
> --
> View this message in context: http://appfuse.547863.n4.nabble.com/Can-AppFuse-3-5-project-deployed-on-jdk-1-6-tp4657868.html
> Sent from the AppFuse - User mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can AppFuse 3.5 project deployed on jdk 1.6?

firepotato
Thank you very much. I got it.
Loading...